15 Sep 2011

Does Tux Like to Move House?

I wrote about a week ago that my laptop which served me for almost 5 years got broken. These were bad news for me.
That laptop hosted all of my quadro-boot systems. Of course, none of inhabitants suffered during the breakage, but they could not live their full-bodied life without window to external world which is laptop's screen.
Recent days brought me some good news. I managed to get the replacement.
This means all inhabitants had to move house.
I previously had similar experience when I tried to replace motherboard and processor in the desktop computer keeping same disk with Windows. It was somewhere in late 1990s. I don't remember whether it was Win95 or WinNT, but result of the move was disastrous. I had to reinstall the system from scratch.
Did things change since that time? Let's see...

Just to remind you who are inhabitants of my harddisk now:
What was the old house?
HP Compaq C300 laptop with following specifications:
  • Intel Celeron M 1.6 GHz
  • 1GB RAM
  • CD-RW and broken DVD-RW
  • Intel video card
  • Broadcom 4311 WiFi card
  • Conexant Audio card
  • Laptop initially came with 80Gb (?) HDD which crashed and was replaced by myself with 500Gb HDD.
  • This laptop had pre-installed Windows XP Media Centre Edition with COA at the bottom.
What is my new laptop and new house for my systems?
Fujitsu-Siemens Amilo Pi 1505 with following specifications:
  • Intel Centrino, dual core 1.73 GHz
  • 1GB RAM
  • CD/DVD-RW in working condition
  • Intel video card
  • Intel 3945ABG WiFi card
  • Realtek HD Audio card
  • Laptop came with 80Gb HDD, but I replace it with 500Gb HDD from my broken Compaq C300.
  • This laptop came with pre-installed Windows Vista Home Premium with COA at the bottom
Some observations on design quality of HP vs Fujitsu-Siemens. In my humble opinion, it is better and safer to open smaller compartments (HP), specifically for HDD and memory sticks, than to open half of the bottom cover with everything available from single place (Fujitsu). Also, as I read from Amilo-related forums, second slot for memory bar is located... under the keyboard! It means you need to de-assemble almost whole piece to reach it!
So, hard disk has been moved across together with all inhabitants. Let's see how they settle in new house!

First boot

  1. Windows XP starts, but with low screen resolution. It immediately recognises that walls around are new and requires activation. Activation does not work over wireless connection. So I will bother with WinXP later.
  2. Debian starts as normal. There are some messages during the boot which I can also see in dmesg, and most of them are about new WiFi card. Debian moans that firmware is missing. Most wonderful is that scrolling on touchpad is working! It was not the case for natively installed Windows Vista.
  3. Linux Mint XFCE starts as normal. Wireless network connects automatically. So, almost everything is like on my previous machine. With 2 exceptions.
    • Screen is slightly blurry.
    • After attempt to play MP3 file from network location and manage volume with keyboard keys (Fn-F5 / Fn-F6), keyboard stopped responding at all, volume reduced to the minimum and got muted.
    So, hard reset.
  4. Mageia boots as normal. Screen is "as normal", not blurry at all. The only immediate issue is about crashing of auto-started KTorrent. Most likely because network is not on. Mageia has same issue with firmware, as Debian had few minutes ago. But Mint XFCE has the firmware! So, firmware files are copied from one partition into other (both to Mageia and Debian partitions). Right after that I made refresh in Network Center, and my wireless network were listed! Isn't it magic??? The only difference with previous network connection is in network name: it is wlan1 now, not wlan0. I don't care and don't mind. When I started Device manager, it recommended me to download newer version of WiFi firmware, which I did. Scrolling on touchpad is working fine, like in Mint XFCE. Unfortunately, sound does not work at all. Device manager shows it like Intel (not Realtek) audio card, probably because it is "on-board" one! Actually, this is the case for all 3 installed Linuxes and for Live run of Simply Linux: lspci lists audio device as
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
So, at this point I faced 3 problems with my Linux systems:
  1. Firmware for Intel Wireless network card is only included into Linux Mint XFCE installed system, not in Debian or Mageia.
  2. Sound card is not working at all in Mageia and gives me glitches with volume control in Debian and Mint XFCE. 
  3. Slightly blurry screen in Linux Mint XFCE. It's least important issue and I can cope with it.
Second boot
  1. Debian. Boots with WiFi connected (firmware files were copied across, you remember). Audio files start playing straight away. But Fn-F6 (reduce volume) again hangs the audio card and keyboard in general. Same in Mint XFCE. At the same time Fn-F5 (increase volume) works fine.
  2. Windows XP. This time I took laptop to network cable. Activation went absolutely fine with product key from the sticker on the bottom of old laptop. Windows found new hardware and successfully installed most of it. Graphic card works absolutely fine. Music plays without any issue and control keyboard keys (both Fn-F5 and Fn-F6) work as they should. Wireless works immediately, but it "forgot" my network, so I had to re-enter the key. Not a big deal. Scrolling on touchpad does not work.
What is the outcome of all this?
The best system to cope with move to absolutely different hardware is... Windows XP. Yes, there are some issues with inability to find driver for "Mass Storage Device", but it is not critical and most used one.
Second in the row is Mint XFCE. It only has issue with audio card and volume controls.
Third is Debian. It did not have drivers for WiFi, but once they were copied, connection worked fine. Unfortunately, same issue about audio card and volume controls as in Mint XFCE.
And last, unfortunately for me, is my favourite Mageia. It did not have driver for wireless. Of course, it started working when firmware files were copied across. But audio did not start there at all.

What does it all mean? Almost nothing.
Experiments with moving disks between different computers are not the most common thing any user does. That's why I am sure developers are not bothered with effects of such move.
I anyway wanted to install my systems afresh on new laptop, as I feel it right to let system install all the components required for the particular hardware. Almost all my "quadro-boot" components will be re-installed in the nearest future. The only exception is WinXP. It coped very well with the move, and I worry about it the least.
Also, as I mentioned earlier, I will replace one of the "boots" during the reinstall... So, I'll keep you posted and you stay tuned!

Have you ever tried to make similar "move" of your systems with your hard disk from one hardware to another?

5 comments:

  1. next time u replace a motherboard use the wired network and update the system the same way u did xp, amazingly with system updates even linux will sometimes work correctly. for xp it is amazing for it not to bluescreen on a motherboard change (unless you had previously run mergeide on it) count yourself lucky. having replaced many motherboards over the last few years i personally would rate xp last.

    ReplyDelete
  2. I have moved one desktop install through three different complete hardware swaps. I installed Debian Woody back in the day and have dist-upgraded it over the years all the way to Squeeze. It has survived being moved to new hard disks via dd, moved from an HP Pavilion 6460 to a home built box with an Abit IL8 MB, to my current board without ever having an issue. Of course, it's a desktop machine and doesn't have wifi or a fancy keyboard with controls...

    ReplyDelete
  3. @Anonymous 1 and 2:
    Yes, I also thought XP would fail at I would have to re-install it. But my expectations were exceeded.
    As for Linuxes, I think that most problems come from fancy equipment, and laptops are usually full of it. You can see that no issues arose from motherboard/memory/chipset level. All of them came from wireless (which is always pain in the ass) and fancy controls.
    Let's see how these controls will work in re-installed systems. If they continue to fail, then there is nothing to blame in "move house" exercise.

    ReplyDelete
  4. Several years ago I had a power supply failure that killed the mobo and cpu, so I replaced those parts as well as the RAM and GPU but kept the old hard drive that I was dual-booting Debian and Windows XP on. Debian started right up, just had to upgrade the Nvidia driver for the new graphics card. Windows XP blue screened on boot repeatedly and had to be reinstalled. I guess experiences vary.

    ReplyDelete
  5. @Shergill Games:
    >I guess experiences vary.
    you're so right!

    ReplyDelete